Support IPS4.4.X IPS 4.4 Sprachvariable/Phrase in bestehendes Sprachpaket hinzufügen

  • Ersteller des Themas
  • #1

escape2k

Registriert
6 April 2019
35
4 %
Hi,

Ich hab IPS 4.4 installiert und das Deutsche sowie englische Sprachpaket.
Weiß einer wie ich eine neue Sprachvariable in eines dieser bestehenden Languagepacks hinzufügen kann?

Das kann ja eigentlich nicht so schwer sein ich finde aber keine option dazu und google hat mir bislang auch nicht weitergeholfen.

Ich hab das ganze nun direkt über die Datenbank (mit phpmyadmin) eingefügt.
Ich wünschte es gäbe ne möglichkeit direkt übers acp neue Sprachvariablen zu erstellen, es sieht aber so aus als wäre das tatsächlich nicht möglich?

Egal hier die Antwort die ich schon auf invision-virus.com gepostet habe wo ich die frage ebenfalls gestellt habe.
Das ist mehr oder weniger ein kleines Tutorial wie man Mehrsprachige Seiten mit der CMS/Pages Application von IPS erstellt:

Step 1:

Open your database with phpmyadmin (or similar) and create a new entry in the table "core_sys_lang_words".
You have to specify a phrase name, phrase content (your page content) and the id of the language pack this phrase should be added to.

If you dont know the id of the language pack you can look it up in the database table "core_sys_lang".
You have to create the phrase for each language pack.

Step 2:
Go to ACP -> Pages -> Add Page -> Manual html

Fill everything accordingly.

In the Content tab place
Code:
{lang="your_phrase_name"}
And save your page.

Step 3:

Now unter Themes -> Languages -> Translate

you can edit it anytime conviently without the need of editing the database directly with phpmyadmin or other tools like that if you should have
to update the page content at some point in the future. :)

-----

Now you guys know how to make multilanguage pages using the page application from ips 4.4.x
If there is a better way let me know but i have not found anything at all. So it appers this post is the first guide there is.

Here it is for free!
 
Reactions: d0c
  • Ersteller des Themas
  • #3

escape2k

Registriert
6 April 2019
35
4 %
Ne damit kannst du nur eine komplett neue Version des Sprachpakets hochladen.
Was ich wollte ist eine option im ACP um neue Sprachvariablen in bestehende Languagepacks einzufügen.
Geht z.b. bei Xenforo und vielen anderen. bei IPS 4.4.x wohl aber nicht bzw. nur wie oben von mir beschrieben.

Naja vllt. im Developer Modus? Müsste ich mal ausprobieren.

Edit:
das hier ist quasi was ich gerne bei IPS im ACP gehabt hätte: :)
https://modjungle.com/attachments/05_add_multiple_phrase-png.29/
 
Zuletzt bearbeitet:

Speddy20537

Szene-Pirat
18 August 2013
1.003
50 %
Ne damit kannst du nur eine komplett neue Version des Sprachpakets hochladen.
Was ich wollte ist eine option im ACP um neue Sprachvariablen in bestehende Languagepacks einzufügen.
Geht z.b. bei Xenforo und vielen anderen. bei IPS 4.4.x wohl aber nicht bzw. nur wie oben von mir beschrieben.

Naja vllt. im Developer Modus? Müsste ich mal ausprobieren.

Edit:
das hier ist quasi was ich gerne bei IPS im ACP gehabt hätte: :)
https://modjungle.com/attachments/05_add_multiple_phrase-png.29/
Ich Glaube wenn du Debug Modus Aktiv hast kannst du template und Sprache hinzufügen ich weis es aber nicht 100 Pro.
 

Speddy20537

Szene-Pirat
18 August 2013
1.003
50 %


  • Details: 15,4 MB 1x [5/5] (WiP) Release-Bewertung (WiP)
  • Ersteller des Themas
  • #7

escape2k

Registriert
6 April 2019
35
4 %
Ich hab die jetzt hochgeladen bekomme aber wenn ich die constants.php erstelle und auf TRUE setzte nur Fehlermeldungen angezeigt.
Wenn ich auf FALSE setze kann ich aber dennoch bereits die templates im acp bearbeiten und bekomme auch keine update meldung mehr angezeigt.

Die frage ist jetzt warum bekomme ich die Fehlermeldungen angezeigt wenn enabled.
A: Weil ich IPS 4.4.2 statt der aktuellen 4.4.10 habe
B: Weil ich plugins installiert habe

Hast du falls nötig auch die Version fürs 4.4.2? (Ich probiere momentan nur rum, wenn ich mich dazu entschließe die Software einzusetzen werde ich eine Lizenz kaufen und dann auch die aktuelle Version benutzen:)

Ansonsten alter Developer Tools mit 5000 Datein, vor 20 Jahren hatten diverse komplette Forensysteme weder Developer Tools noch groß mehr als 1000 oder 2000 Datein. Das wird alles echt immer lächerlicher mit diesem zusätzlich ballast und komplexität was eigentlich keiner braucht... naja egal. :D

Ich hab mir jetzt ne ältere Version besorgt und damit klappt es.
Allerdings finde ich auch hier keine Option um eine Phrase hinzuzufügen.
Scheint wohl wirklich nur direkt über datenbank mit z.b. phpmyadmin zu gehen so wie von mir oben beschrieben.

Falls ich was übersehe natürlich gerne bescheidgeben. :)
 
Reactions: d0c

Speddy20537

Szene-Pirat
18 August 2013
1.003
50 %
Ich hab die jetzt hochgeladen bekomme aber wenn ich die constants.php erstelle und auf TRUE setzte nur Fehlermeldungen angezeigt.
Wenn ich auf FALSE setze kann ich aber dennoch bereits die templates im acp bearbeiten und bekomme auch keine update meldung mehr angezeigt.

Die frage ist jetzt warum bekomme ich die Fehlermeldungen angezeigt wenn enabled.
A: Weil ich IPS 4.4.2 statt der aktuellen 4.4.10 habe
B: Weil ich plugins installiert habe

Hast du falls nötig auch die Version fürs 4.4.2? (Ich probiere momentan nur rum, wenn ich mich dazu entschließe die Software einzusetzen werde ich eine Lizenz kaufen und dann auch die aktuelle Version benutzen:)

Ansonsten alter Developer Tools mit 5000 Datein, vor 20 Jahren hatten diverse komplette Forensysteme weder Developer Tools noch groß mehr als 1000 oder 2000 Datein. Das wird alles echt immer lächerlicher mit diesem zusätzlich ballast und komplexität was eigentlich keiner braucht... naja egal. :D

Ich hab mir jetzt ne ältere Version besorgt und damit klappt es.
Allerdings finde ich auch hier keine Option um eine Phrase hinzuzufügen.
Scheint wohl wirklich nur direkt über datenbank mit z.b. phpmyadmin zu gehen so wie von mir oben beschrieben.

Falls ich was übersehe natürlich gerne bescheidgeben. :)

Ich muss das naher mal testen wenn ich zu hause bin warum du ne Fehler meldung bekommst.

Welche php vversion benutz Dispro benutz du.